• Stars
    star
    2
  • Language
    Nix
  • Created almost 2 years ago
  • Updated 6 months ago

Reviews

There are no reviews yet. Be the first to send feedback to the community and the maintainers!

Repository Details

Dotfiles powered by Nix and home-manager

dotfiles.nix

This repository contains a Nix file, pepicrft.nix, that I use to provision the environments from where I work.

Set it up

  1. Install Nix: sh <(curl -L https://nixos.org/nix/install) --daemon.
  2. Enable flakes:
mkdir -p ~/.config/nix

cat <<EOF >> ~/.config/nix/nix.conf
experimental-features = nix-command flakes
EOF
  1. Restart the Nix daemon:
sudo launchctl kickstart -k system/org.nixos.nix-daemon
  1. Install a tool to create a profile: nix-env -i comma.
  2. Create a symlink at ~/.config/nixpkgs that points to the repository directory:
ln -s {path-to-repo} ~/.config/nixpkgs
  1. Run nix run . switch in the repository directory.
  2. Update iTerm's Command setting under the Profile tab to use the custom shell: ~/.nix-profile/bin/zsh
  3. Update the VSCode settings to use the ZSH managed by Nix:
{
    "editor.inlineSuggest.enabled": true,
    "terminal.integrated.profiles.osx": {
        "Nix-managed ZSH": {
          "path": "/Users/pepibumur/.nix-profile/bin/zsh"
        }
    },
    "terminal.integrated.defaultProfile.windows": "Nix-managed ZSH"
}

Troubleshooting

Nix breaks on macOS updates

Add the following to the /etc/zshrc file:

if [ -e '/nix/var/nix/profiles/default/etc/profile.d/nix-daemon.sh' ]; then
  source '/nix/var/nix/profiles/default/etc/profile.d/nix-daemon.sh'
fi

Useful commands

  • nix run . switch: Run it whenever we change something in the home manager configuration.
  • nix flake update: Update the programs in the dependency graph and reflect the updates in the lockfile.

More Repositories

1

PPiAwesomeButton

UIButton category with new methods to setup a button with text + FontAwesome Icon
Objective-C
496
star
2

catalysis-framework

A full-stack Javascript framework · Built for the long-term
TypeScript
51
star
3

xcode-modular-apps-workshop

Mobos Conference (Romania) about building modular apps with Xcode
Swift
23
star
4

typed-file-system-path

📃 Typed primitives for Typescript to work with file paths
TypeScript
7
star
5

developing-modular-apps-on-ios

Slides from the talk that I gave at NSCoder Night Madrid
7
star
6

node-module-benchmarker

🚀 A CLI to benchmark the loading of an ESM graph in Node
TypeScript
3
star
7

pepicrft.me

🐣 Personal website powered by Phoenix (pepicrft.me)
Elixir
3
star
8

gestalt

🎨 A Rust-powered and language-agnostic solution to build interactive UIs for web apps
2
star
9

intrepid-adventure-of-scaling-mobile-apps-talk

The slides of my presentation "The intrepid adventure of scaling a mobile apps"
2
star
10

modulex

📦 Generate a module whose implementation can be swapped at runtime with tools like Mox
Elixir
1
star
11

detect-create-package-manager

An NPM package to detect the package manager used for running the "create" command
TypeScript
1
star
12

still_scss

🎨 A scss preprocessor for the Still static site generator
Elixir
1
star
13

noora

🌱 Noora is a native UI compiler for the web
1
star
14

encrypted-environment

Ruby utility to load encrypted variables into the environment
Ruby
1
star
15

WDM_over_POF

Analysis and viability of WDM technology in POF networks - Final degree project
TeX
1
star
16

rssletter

✉️ Turn newsletter subscriptions into a RSS feed
Elixir
1
star
17

website-old

🌍 Pedro Piñera's personal static website
HTML
1
star
18

pepicrft.me-next

👩‍🚀 Personal website implemented with NextJS
JavaScript
1
star
19

gestaltjs

A full-stack and batteries-included NodeJS framework designed and built for the long-term
1
star
20

Tratamiento-Digital-de-Im-genes-iOS

Asignatura de tratamiento de digital de imágenes trasladada a iOS con todos los ejercicios de la asignatura.
Objective-C
1
star
21

simple-dynamic-configuration-tuist

A repository that showcases how to use dynamic configuration in Tuist
Swift
1
star
22

bodamariajoseypedro

JavaScript
1
star
23

solare

Solare is an iOS application to alert user how dangerous UV is
Objective-C
1
star
24

pepicrft

1
star